Voice provider outage

Incident Report for Shasta Health

Resolved

The fix has been implement and calling agents are operational.
Posted Aug 19, 2026 - 12:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2026 - 12:56 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 19, 2026 - 12:30 PDT

Investigating

Our 3rd party vendor for handling voice calls is experiencing widespread outages. We are working with them to investigate.
Posted Aug 19, 2026 - 11:23 PDT
This incident affected: Calling Agent.